Сообщения в 1С

В этой статье разберем, как работать с сообщениями в 1С. Узнаем такие методы, как Сообщить, Предупреждение и ПоказатьПредупреждение.

Метод Сообщить в 1С

Самый простой способ вывести сообщение пользователю 1С — это метод Сообщить. Замечу, что данный метод работает практически на всех видах клиентов. Синтаксис у него достаточно простой: Сообщить(<Текстовое сообщение>). Вы просто в скобках пишите или текстовое сообщение в кавычках, или указываете в качестве параметра переменную с типом строка.

В коде ниже, при открытии управляемой формы обработки выводится сообщение.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Сообщить("Привет с сервера!!!");
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	СтрокаПривет = "Привет с клиента!!!"
	Сообщить(СтрокаПривет);
КонецПроцедуры

Причем, первое сообщение выводится, когда код выполняется в серверном контексте, а второе, когда код выполняется в клиентском контексте. Результатом выполнения этого кода будут сообщения внизу формы.

Сообщить 1С

Метод Предупреждение в 1С

Метод Предупреждение выводит сообщение пользователю в виде отдельного окна, и в отличие от метода Сообщить, этот метод работает на тонком, толстом и мобильном клиенте, т.е. использовать его в серверном контексте не получится, как мы это сделали в предыдущем примере с методом Сообщить.

Этот метод имеет следующий синтаксис:

Предупреждение(<Текст предупреждения>,<Таймаут>,<Заголовок окна>)

Где:

Текст предупреждения – или непосредственно текст предупреждения, или переменная с типом строка;

Таймаут  — число, которое указывает, сколько секунд будет отображаться окно с предупреждением, необязательное поле, по умолчанию 0;

Заголовок окна – текст или переменная с типом строка, это значение будет в заголовке окна с предупреждением.

В качестве примера, на форме обработки я создал команду, в которой вывожу предупреждение:

&НаКлиенте
Процедура ВывестиПредупреждение(Команда)
	перемНазваниеОкна = "Это наше окно";
	Предупреждение("Вывели текст предупреждения",,перемНазваниеОкна);
КонецПроцедуры

И результат работы:

Предупреждение в  1С

А если установить таймаут (второй параметр), то через указанное количество секунд окно закроется.

перемНазваниеОкна = "Это наше окно";
Предупреждение("Вывели текст предупреждения",10,перемНазваниеОкна);

Замечу, что этот метод работает только тогда, когда у конфигурации включен режим использования модальности. Посмотреть на то, какое значение у этого режима можно в палитре свойств конфигурации:

Палитра свойств  конфигурации в  1С

Если у свойства «Режим использования модальности» установлено значение «Использовать» или «Использовать с предупреждениями», то методом Предупреждение можно  пользоваться, иначе, если установлено значении «Не использовать», возникнет ошибка «Использование модальных окон в данном режим запрещено!».

Использование модальных окон в данном режим запрещено

В конфигурациях с таким режимом использования модальности следует применять метод ПоказатьПредупреждение.

Метод ПоказатьПредупреждение в  1С

У этого метода похожий синтаксис:

ПоказатьПредупреждение(<Описание оповещения о завершении><Текст предупреждения>,<Таймаут>,<Заголовок окна>)

Описание оповещения о Завершении – описание процедуры, которая будет вызвана после закрытия окна предупреждения.

В остальном синтаксис, кроме первого параметра, такой же, как и у метода Предупреждение, поэтому, если мы хотим просто вывести сообщение, без отработки закрытия окна, то решение будет следующим:

перемНазваниеОкна = "Это наше окно";
ПоказатьПредупреждение(,"Вывели текст предупреждения",,перемНазваниеОкна);

Просто, первый параметр оставляем пустым.

Замечу, что метод ПоказатьПредупреждение работает как с включенной, так и с выключенной модальностью, поэтому в Ваших разработках я рекомендую применять именно этот метод!

Подробно о том, как работает метод ПоказатьПредупреждение с первым параметром «Описание оповещения о завершении» читайте в статье ниже:

Изучаем немодальные окна

Более подробно и основательно начальные вопросы программирования в 1С вы можете изучить в

книге «Программировать в 1С за 11 шагов»

Изучайте программирование в 1С в месте с моей книгой «Программировать в 1С за 11 шагов»

Программировать в 1С за 11 шагов

Книга написана понятным и простым языком — для новичка.

  1. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  2. Научитесь понимать архитектуру 1С;
  3. Станете писать код на языке 1С;
  4. Освоите основные приемы программирования;
  5. Закрепите полученные знания при помощи задачника.

О том как разрабатывать под управляемым приложением 1С, читайте в книге Книга «Основы разработки в 1С: Такси»

Отличное пособие по разработке в управляемом приложении 1С, как для начинающих разработчиков, так и для опытных программистов.

Основы разработки в 1С такси
  1. Очень доступный и понятный язык изложения
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Поймете идеологию управляемого приложения 1С
  4. Узнаете, как разрабатывать управляемое приложение;
  5. Научитесь разрабатывать управляемые формы 1С;
  6. Сможете работать с основными и нужными элементами управляемых форм
  7. Программирование под управляемым приложением станет понятным

Промо-код на скидку в 15% — 48PVXHeYu


Эти книги, плюс книга по программированию оперативного учета имеются в едином комплекте: комплект книг по разработке в 1С.
Только для читателей моего блога,
промо-код на скидку в 300 рублей на весь комплект: blog


Если Вам понравился этот урок, был полезен или помог решить какую-нибудь проблему, то Вы можете поддержать мой проект, перечислив любую сумму
.

можно оплатить вручную:

Яндекс.Деньги — 410012882996301
Web Money — R955262494655

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

восемь + четыре =