Строки таблицы значений в 1С 8.2 (8.3)

Любая таблица значений состоит из колонок, каждая из которых имеет свой тип и уникальное название, а также из строк. Если таблица значений размещена на управляемой форме в виде элемента Таблица, то колонки создаются изначально на этапе разработки, а строки пользователь может создать самостоятельно, нажав на кнопку «Добавить» в командной панели этой таблицы.

Для добавления новой строки нужно нажать на кнопку добавить

Также пользователь может удалять строки или перемещать. Но, гораздо интереснее программная работа со строками таблицы значений.

Программное добавление строк таблицы значений в 1С

В платформе 1С 8.2 — 8.3 разработчик имеет возможность добавлять строки таблицы значений непосредственно с помощью языка разработки, работая в конфигураторе 1С.

Для того чтобы создать новую строку таблицы значений, используется метод Добавить, данный метод не имеет параметров и является функцией.

Новая строка таблицы значений создается следующим образом:

НоваяСтрока = ФИО.Добавить();

Как видите, с помощью метода Добавить мы создали переменную НоваяСтрока, тип значения которой Строка таблицы значений. Но, просто создать строку мало, нам еще необходимо записать в нее определенные данные. Как получить доступ к колонкам данной строки?

Осуществить это можно двумя способами:

Первый способ:

НоваяСтрока.Фамилия = «Иванов»;

Второй способ:

НоваяСтрока[1] = «Иван»;

В первом способе мы получаем доступ к колонке как к свойству через точку, во втором — используя оператор квадратные скобки и указывая в них номер индекса колонки. Я предпочитаю первый способ, так как он делает код гораздо лучше читаемым и наглядным.

Допустим, у нас есть некоторая таблица значений ФИО с колонками Фамилия, Имя, Отчество, ФИО и ДатаРождения, то добавить новую строку этой таблицы и заполнить колонки этой строки можно следующим образом.

НоваяСтрока = ФИО.Добавить();
НоваяСтрока.Фамилия = «Иванов»;
НоваяСтрока[1] = «Иван»;
НоваяСтрока.Отчество = «Петрович»;
НоваяСтрока.ДатаРождения = ‘19800209’;
НоваяСтрока.ФИО = НоваяСтрока.Фамилия +» » +
Лев(НоваяСтрока.Имя,1) +«.» +
Лев(НоваяСтрока.Отчество,1) + «.»;

С помощью метода Добавить мы создаем строку, которая вставляется в конец таблицы значений. Для того чтобы поместить строку в нужное место таблицы значений, необходимо использовать метод Вставить. Параметром данного метода является индекс, на который вставляется данная строка.

Добавим с помощью этого метода еще одну строку в таблицу ФИО. И поставим ее на первое место.

НоваяСтрока = ФИО.Вставить(0);
НоваяСтрока.Фамилия = «Петров»;
НоваяСтрока.Имя     = «Игорь»;
НоваяСтрока.Отчество = «Андреевич»;
НоваяСтрока.ФИО = НоваяСтрока.Фамилия +» » + Лев(НоваяСтрока.Имя,1) +«.» + Лев(НоваяСтрока.Отчество,1) + «.»;
НоваяСтрока.ДатаРождения = ‘19850909’;

Программный обход строк таблицы значений в 1С

Узнаем как обходить сроки таблицы. Это можно осуществлять с помощью операторов цикла Для каждого…Цикл и Для…Цикл.

Оператор цикла Для каждого…Цикл.

Для Каждого Стр из ФИО цикл
   
Сообщить(Стр.ФИО + «, дата рождения » +
   
Формат(Стр.ДатаРождения,«ДЛФ = ДД»));
КонецЦикла;

С  помощью этого оператора мы обходим все строки таблицы значений. Переменная Стр принимает значения каждой строки таблицы в порядке обхода. Тип данной переменной — Строка таблицы значений, поэтому мы можем спокойно обращаться к колонкам данной строки, используя точку или квадратные скобки.

Оператор цикла Для…Цикл.

Для н = 0 по ФИО.Количество() — 1 цикл
   
Сообщить(ФИО[н].ФИО + «, дата рождения » +
   
Формат(ФИО[н].ДатаРождения,«ДЛФ = ДД»));
КонецЦикла;

В этом цикле нам необходимо получить индексы всех строк, для этого мы осуществляем обход, начиная с нуля и заканчивая значением, которое возвращает метод Количество за минусом единицы.

Когда мы используем квадратные скобки применительно к таблице значений (например, ФИО[н]), то результатом данной операции является строка таблицы с соответствующим индексом.

Индекс строки таблицы значений

Каждая строка имеет свой уникальный индекс. Все индексы идут по порядку и начинаются с 0. Для того, чтобы узнать индекс нужно строки необходимо применить метод Индекс таблицы значений, где в качестве параметра указать нужную строк.

Для Каждого Стр из ФИО цикл
   
Сообщить(Стр.ФИО + «, дата рождения » +
   
Формат(Стр.ДатаРождения,«ДЛФ = ДД»));
   
Инд = ФИО.Индекс(Стр)
КонецЦикла;

В этом коде в переменную Инд будет записываться индекс строки при каждой итерации цикла.

Программное удаление строк таблицы значений

Для программного удаление определенной строки таблицы значений нужно использовать метод Удалить этой таблицы. В качестве параметра указывается или индекс нужной строки или сама строка.

ФИО.Удалить(0)

У новичков основные сложности возникают, когда нужно удалить несколько строк из таблицы значений. Если делать обход таблицы значений циклом, то данное удаление пройдет не совсем корректно. Я в этом случае поступаю так: сохраняю нужные строки в массиве, а потом обхожу этот массив циклом и уже в нем их все удаляю. Получается примерно так:

МассивДляУдаления = Новый Массив;
Для Каждого
Стр из ФИО цикл
    Если тогда
//какое-то условие
       
МассивДляУдаления.Добавить(Стр);
    КонецЕсли
КонецЦикла;
Для Каждого
СтрМассива из МассивДляУдаления Цикл
   
ФИО.Удалить(стрМассива)
КонецЦикла

Таблица значений 1С: работа с колонками

Таблица значений 1С

 

Более подробно о работе с таблицами значений и другими интересными объектами языка программирования в 1С читайте в моей книге «Программировать в 1С за 11 шагов»

Книга «Программировать в 1С за 11 шагов»

Изучайте программирование в 1С в месте с моей книги «Программировать в 1С за 11 шагов»

  1. Книга написана понятным и простым языком — для новичка.
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Научитесь понимать архитектуру 1С;
  4. Станете писать код на языке 1С;
  5. Освоите основные приемы программирования;
  6. Закрепите полученные знания при помощи задачника;

Книга «Основы разработки в 1С: Такси»

Отличное пособие по разработке в управляемом приложении 1С, как для начинающих разработчиков, так и для опытных программистов.

  1. Очень доступный и понятный язык изложения
  2. Книга посылается на электронную почту в формате PDF. Можно открыть на любом устройстве!
  3. Поймете идеологию управляемого приложения 1С
  4. Узнаете, как разрабатывать управляемое приложение;
  5. Научитесь разрабатывать управляемые формы 1С;
  6. Сможете работать с основными и нужными элементами управляемых форм
  7. Программирование под управляемым приложением станет понятным

Промо-код на скидку в 15% — 48PVXHeYu


Если Вам помог этот урок решить какую-нибудь проблему, понравился или оказался полезен, то Вы можете поддержать мой проект, перечислив любую сумму:

можно оплатить вручную:

Яндекс.Деньги — 410012882996301
Web Money — R955262494655

Вступайте в мои группы:

Вконтакте: https://vk.com/1c_prosto
Фейсбуке: https://www.facebook.com/groups/922972144448119/
ОК: http://ok.ru/group/52970839015518
Твиттер: https://twitter.com/signum2009

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

7 + 4 =